vcl: Only exclude vcl ldpreload on FreeBSD
[vpp.git] / src / vcl / CMakeLists.txt
index 2f738f3..c8835e7 100644 (file)
 # See the License for the specific language governing permissions and
 # limitations under the License.
 
-if(NOT "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
-  message(WARNING "-- vppcom is currently only support on Linux - disabled")
-  return()
-endif()
-
 ##############################################################################
 # vppcom shared library
 ##############################################################################
@@ -40,6 +35,9 @@ if (LDP_HAS_GNU_SOURCE)
   add_compile_definitions(HAVE_GNU_SOURCE)
 endif(LDP_HAS_GNU_SOURCE)
 
+if("${CMAKE_SYSTEM_NAME}" STREQUAL "FreeBSD")
+  message("WARNING: vcl_ldpreload isn't supported on FreeBSD - disabled")
+else()
 add_vpp_library(vcl_ldpreload
   SOURCES
   ldp_socket_wrapper.c
@@ -48,6 +46,7 @@ add_vpp_library(vcl_ldpreload
   LINK_LIBRARIES
   vppinfra svm vlibmemoryclient rt pthread vppcom dl
 )
+endif()
 
 add_vpp_headers(vcl
   ldp.h