vcl: add support for app socket api
[vpp.git] / src / vcl / CMakeLists.txt
index 9fead60..e6d8f98 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (c) 2018 Cisco and/or its affiliates.
+# Copyright (c) 2018-2019 Cisco and/or its affiliates.
 # Licensed under the Apache License, Version 2.0 (the "License");
 # you may not use this file except in compliance with the License.
 # You may obtain a copy of the License at:
@@ -20,6 +20,8 @@ add_vpp_library(vppcom
   vcl_bapi.c
   vcl_cfg.c
   vcl_private.c
+  vcl_locked.c
+  vcl_sapi.c
 
   LINK_LIBRARIES
   vppinfra svm vlibmemoryclient rt pthread
@@ -39,27 +41,8 @@ add_vpp_library(vcl_ldpreload
 
 add_vpp_headers(vcl
   ldp.h
-  sock_test.h
   ldp_glibc_socket.h
-  vcl_test.h
   vppcom.h
+  vcl_locked.h
   ldp_socket_wrapper.h
-  sock_test_common.h
-)
-
-##############################################################################
-# vcl tests
-##############################################################################
-option(VPP_BUILD_VCL_TESTS "Build vcl tests." ON)
-if(VPP_BUILD_VCL_TESTS)
-  foreach(test
-    vcl_test_server
-    vcl_test_client
-    sock_test_server
-    sock_test_client
-  )
-    add_vpp_executable(${test} SOURCES ${test}.c LINK_LIBRARIES vppcom pthread
-                      NO_INSTALL)
-  endforeach()
-endif(VPP_BUILD_VCL_TESTS)
-
+)
\ No newline at end of file