qos: Store function
[vpp.git] / src / vnet / CMakeLists.txt
index 467d82b..05a8077 100644 (file)
@@ -71,6 +71,7 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES
   interface.api
+  interface_types.api
   ip/ip_types.api
 )
 
@@ -155,7 +156,9 @@ list(APPEND VNET_HEADERS
   ethernet/p2p_ethernet.h
 )
 
-list(APPEND VNET_API_FILES ethernet/p2p_ethernet.api)
+list(APPEND VNET_API_FILES
+  ethernet/p2p_ethernet.api
+  ethernet/ethernet_types.api)
 
 ##############################################################################
 # Layer 2 protocol: Ethernet bridging
@@ -629,6 +632,7 @@ list(APPEND VNET_SOURCES
   tcp/tcp_input.c
   tcp/tcp_newreno.c
   tcp/tcp_cubic.c
+  tcp/tcp_bt.c
   tcp/tcp.c
 )
 
@@ -675,33 +679,6 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES udp/udp.api)
 
-##############################################################################
-# Layer 4 protocol: sctp
-##############################################################################
-list(APPEND VNET_SOURCES
-  sctp/sctp_api.c
-  sctp/sctp.c
-  sctp/sctp_pg.c
-  sctp/sctp_input.c
-  sctp/sctp_output.c
-  sctp/sctp_output_node.c
-  sctp/sctp_format.c
-)
-
-list(APPEND VNET_MULTIARCH_SOURCES
-  sctp/sctp_output_node.c
-  sctp/sctp_input.c
-)
-
-list(APPEND VNET_HEADERS
-  sctp/sctp_error.def
-  sctp/sctp_packet.h
-  sctp/sctp_timer.h
-  sctp/sctp.h
-)
-
-list(APPEND VNET_API_FILES sctp/sctp.api)
-
 ##############################################################################
 # Tunnel protocol: gre
 ##############################################################################
@@ -1314,6 +1291,7 @@ list(APPEND VNET_SOURCES
   fib/fib_entry_src_lisp.c
   fib/fib_entry_cover.c
   fib/fib_entry_delegate.c
+  fib/fib_entry_track.c
   fib/fib_path_list.c
   fib/fib_path.c
   fib/fib_path_ext.c
@@ -1336,6 +1314,8 @@ list(APPEND VNET_HEADERS
   fib/fib_entry_delegate.h
 )
 
+list(APPEND VNET_API_FILES fib/fib_types.api)
+
 ##############################################################################
 # ADJ
 ##############################################################################
@@ -1390,6 +1370,7 @@ list(APPEND VNET_SOURCES
   dpo/mpls_label_dpo.c
   dpo/l3_proxy_dpo.c
   dpo/dvr_dpo.c
+  dpo/pw_cw.c
 )
 
 list(APPEND VNET_MULTIARCH_SOURCES
@@ -1443,6 +1424,8 @@ list(APPEND VNET_HEADERS
   mfib/mfib_table.h
 )
 
+list(APPEND VNET_API_FILES mfib/mfib_types.api)
+
 ##############################################################################
 # Utilities
 ##############################################################################
@@ -1468,6 +1451,8 @@ list(APPEND VNET_SOURCES
   qos/qos_egress_map.c
   qos/qos_record.c
   qos/qos_record_node.c
+  qos/qos_store.c
+  qos/qos_store_node.c
   qos/qos_mark.c
   qos/qos_mark_node.c
 )
@@ -1551,29 +1536,3 @@ add_vpp_library(vnet
 )
 
 ##############################################################################
-# Session echo apps
-##############################################################################
-
-option(VPP_BUILD_SESSION_ECHO_APPS "Build session echo apps." ON)
-if(VPP_BUILD_SESSION_ECHO_APPS)
-  add_vpp_executable(tcp_echo
-    SOURCES ../tests/vnet/session/tcp_echo.c
-    LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
-    DEPENDS api_headers
-    NO_INSTALL
-    )
-  add_vpp_executable(quic_echo
-    SOURCES ../tests/vnet/session/quic_echo.c
-    LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
-    DEPENDS api_headers
-    NO_INSTALL
-    )
-  add_vpp_executable(udp_echo
-    SOURCES ../tests/vnet/session/udp_echo.c
-    LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
-    DEPENDS api_headers
-    NO_INSTALL
-    )
-endif(VPP_BUILD_SESSION_ECHO_APPS)
-
-##############################################################################