misc: deprecate gbp and its dependents
[vpp.git] / src / vnet / CMakeLists.txt
index 5e1cbc2..5dd7cdb 100644 (file)
@@ -56,7 +56,6 @@ list(APPEND VNET_HEADERS
   devices/netlink.h
   flow/flow.h
   global_funcs.h
-  handoff.h
   interface/rx_queue_funcs.h
   interface/tx_queue_funcs.h
   interface.h
@@ -779,30 +778,6 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES mpls/mpls.api)
 
-##############################################################################
-# Tunnel protocol: vxlan-gbp
-##############################################################################
-list(APPEND VNET_SOURCES
-  vxlan-gbp/decap.c
-  vxlan-gbp/encap.c
-  vxlan-gbp/vxlan_gbp_api.c
-  vxlan-gbp/vxlan_gbp.c
-  vxlan-gbp/vxlan_gbp_packet.c
-)
-
-list (APPEND VNET_MULTIARCH_SOURCES
-  vxlan-gbp/decap.c
-  vxlan-gbp/encap.c
-)
-
-list(APPEND VNET_HEADERS
-  vxlan-gbp/vxlan_gbp.h
-  vxlan-gbp/vxlan_gbp_packet.h
-  vxlan-gbp/vxlan_gbp_error.def
-)
-
-list(APPEND VNET_API_FILES vxlan-gbp/vxlan_gbp.api)
-
 ##############################################################################
 # Tunnel protocol: vxlan-gpe
 ##############################################################################
@@ -889,6 +864,7 @@ list(APPEND VNET_SOURCES
   hash/hash.c
   hash/cli.c
   hash/crc32_5tuple.c
+  hash/handoff_eth.c
 )
 
 list(APPEND VNET_HEADERS
@@ -1223,6 +1199,9 @@ list(APPEND VNET_HEADERS
   fib/fib.h
   fib/fib_api.h
   fib/ip4_fib.h
+  fib/ip4_fib_8.h
+  fib/ip4_fib_16.h
+  fib/ip4_fib_hash.h
   fib/ip6_fib.h
   fib/fib_types.h
   fib/fib_table.h
@@ -1522,10 +1501,14 @@ add_vpp_library (vatclient
 )
 
 add_vat_test_library(vnet
+  interface_test.c
   ip/ip_test.c
   arp/arp_test.c
   ip6-nd/ip6_nd_test.c
   srmpls/sr_mpls_test.c
+  session/session_test.c
+  l2/l2_test.c
+  ipsec/ipsec_test.c
 )
 
 ##############################################################################