ipip: Tunnel flags controlling copying data to/from payload/encap
[vpp.git] / src / vnet / CMakeLists.txt
index a10ec82..658e8d9 100644 (file)
@@ -37,7 +37,12 @@ list(APPEND VNET_SOURCES
   interface_output.c
   interface_stats.c
   misc.c
-  replication.c
+)
+
+list(APPEND VNET_MULTIARCH_SOURCES
+  interface_output.c
+  interface_stats.c
+  handoff.c
 )
 
 list(APPEND VNET_HEADERS
@@ -53,10 +58,10 @@ list(APPEND VNET_HEADERS
   interface_funcs.h
   ip/ip4_to_ip6.h
   ip/ip6_to_ip4.h
+  ip/ip_types_api.h
   l3_types.h
   plugin/plugin.h
   pipeline.h
-  replication.h
   vnet.h
   vnet_all_api_h.h
   vnet_msg_enum.h
@@ -64,7 +69,11 @@ list(APPEND VNET_HEADERS
   util/refcount.h
 )
 
-list(APPEND VNET_API_FILES interface.api)
+list(APPEND VNET_API_FILES
+  interface.api
+  interface_types.api
+  ip/ip_types.api
+)
 
 ##############################################################################
 # Policer infra
@@ -76,6 +85,10 @@ list(APPEND VNET_SOURCES
   policer/policer_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  policer/node_funcs.c
+)
+
 list(APPEND VNET_HEADERS
   policer/police.h
   policer/policer.h
@@ -95,6 +108,12 @@ list(APPEND VNET_SOURCES
   cop/cop_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  cop/node1.c
+  cop/ip4_whitelist.c
+  cop/ip6_whitelist.c
+)
+
 list(APPEND VNET_HEADERS
   cop/cop.h
 )
@@ -109,9 +128,11 @@ list(APPEND VNET_API_FILES cop/cop.api)
 # Layer 2 protocol: Ethernet
 ##############################################################################
 list(APPEND VNET_SOURCES
+  ethernet/ethernet_types_api.c
   ethernet/format.c
   ethernet/init.c
   ethernet/interface.c
+  ethernet/mac_address.c
   ethernet/node.c
   ethernet/pg.c
   ethernet/sfp.c
@@ -120,18 +141,24 @@ list(APPEND VNET_SOURCES
   ethernet/p2p_ethernet_api.c
 )
 
-list(APPEND VNET_MULTIARCH_SOURCES l2/l2_output.c)
+list(APPEND VNET_MULTIARCH_SOURCES
+  ethernet/node.c
+  ethernet/p2p_ethernet_input.c
+)
 
 list(APPEND VNET_HEADERS
   ethernet/error.def
   ethernet/ethernet.h
+  ethernet/mac_address.h
   ethernet/packet.h
   ethernet/types.def
   ethernet/sfp.h
   ethernet/p2p_ethernet.h
 )
 
-list(APPEND VNET_API_FILES ethernet/p2p_ethernet.api)
+list(APPEND VNET_API_FILES
+  ethernet/p2p_ethernet.api
+  ethernet/ethernet_types.api)
 
 ##############################################################################
 # Layer 2 protocol: Ethernet bridging
@@ -141,6 +168,7 @@ list(APPEND VNET_SOURCES
   l2/l2_api.c
   l2/l2_bd.c
   l2/l2_bvi.c
+  l2/l2_bvi_node.c
   l2/l2_input_classify.c
   l2/l2_output_classify.c
   l2/l2_efp_filter.c
@@ -152,12 +180,33 @@ list(APPEND VNET_SOURCES
   l2/l2_learn.c
   l2/l2_output.c
   l2/l2_in_out_acl.c
+  l2/l2_in_out_feat_arc.c
   l2/l2_patch.c
   l2/l2_rw.c
+  l2/l2_uu_fwd.c
   l2/l2_vtr.c
   l2/l2_xcrw.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  l2/l2_bvi_node.c
+  l2/l2_fwd.c
+  l2/l2_learn.c
+  l2/l2_output.c
+  l2/l2_patch.c
+  l2/l2_in_out_feat_arc.c
+  l2/l2_input_classify.c
+  l2/l2_input.c
+  l2/l2_output_classify.c
+  l2/l2_flood.c
+  l2/l2_uu_fwd.c
+  l2/l2_efp_filter.c
+  l2/l2_rw.c
+  l2/l2_xcrw.c
+  l2/l2_in_out_acl.c
+  l2/l2_input_vtr.c
+)
+
 list(APPEND VNET_HEADERS
   l2/feat_bitmap.h
   l2/l2_input.h
@@ -258,6 +307,10 @@ list(APPEND VNET_SOURCES
   vxlan/vxlan_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  vxlan/encap.c
+)
+
 list(APPEND VNET_HEADERS
   vxlan/vxlan.h
   vxlan/vxlan_packet.h
@@ -278,6 +331,11 @@ list(APPEND VNET_SOURCES
   geneve/geneve_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  geneve/encap.c
+  geneve/decap.c
+)
+
 list(APPEND VNET_HEADERS
   geneve/geneve.h
   geneve/geneve_packet.h
@@ -300,7 +358,7 @@ list(APPEND VNET_HEADERS
   bonding/node.h
 )
 
-list(APPEND VNET_MULTIARCH_SOURCES bonding/node.c)
+list(APPEND VNET_MULTIARCH_SOURCES bonding/node.c bonding/device.c)
 list(APPEND VNET_API_FILES bonding/bond.api)
 
 ##############################################################################
@@ -326,6 +384,7 @@ list(APPEND VNET_API_FILES lldp/lldp.api)
 ##############################################################################
 list(APPEND VNET_SOURCES
   classify/vnet_classify.c
+  classify/trace_classify.h
   classify/ip_classify.c
   classify/in_out_acl.c
   classify/policer_classify.c
@@ -335,8 +394,14 @@ list(APPEND VNET_SOURCES
   classify/classify_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  classify/ip_classify.c
+  classify/flow_classify_node.c
+)
+
 list(APPEND VNET_HEADERS
   classify/vnet_classify.h
+  classify/trace_classify.h
   classify/in_out_acl.h
   classify/policer_classify.h
   classify/flow_classify.h
@@ -366,7 +431,8 @@ list(APPEND VNET_SOURCES
   ip/ip4_pg.c
   ip/ip4_source_and_port_range_check.c
   ip/ip4_source_check.c
-  ip/ip4_reassembly.c
+  ip/reass/ip4_full_reass.c
+  ip/reass/ip4_sv_reass.c
   ip/ip6_format.c
   ip/ip6_forward.c
   ip/ip6_ll_table.c
@@ -376,7 +442,8 @@ list(APPEND VNET_SOURCES
   ip/ip6_input.c
   ip/ip6_neighbor.c
   ip/ip6_pg.c
-  ip/ip6_reassembly.c
+  ip/reass/ip6_full_reass.c
+  ip/reass/ip6_sv_reass.c
   ip/rd_cp.c
   ip/ip_neighbor.c
   ip/ip_api.c
@@ -385,10 +452,28 @@ list(APPEND VNET_SOURCES
   ip/ip.c
   ip/ip_init.c
   ip/ip_in_out_acl.c
+  ip/ip_punt_drop.c
+  ip/ip_types.c
   ip/lookup.c
-  ip/ping.c
   ip/punt_api.c
   ip/punt.c
+  ip/punt_node.c
+)
+
+list(APPEND VNET_MULTIARCH_SOURCES
+  ip/ip4_source_check.c
+  ip/ip4_punt_drop.c
+  ip/reass/ip4_full_reass.c
+  ip/ip6_hop_by_hop.c
+  ip/reass/ip6_full_reass.c
+  ip/reass/ip4_sv_reass.c
+  ip/ip6_hop_by_hop.c
+  ip/reass/ip6_full_reass.c
+  ip/reass/ip6_sv_reass.c
+  ip/ip6_input.c
+  ip/ip6_punt_drop.c
+  ip/punt_node.c
+  ip/ip_in_out_acl.c
 )
 
 list(APPEND VNET_HEADERS
@@ -411,6 +496,7 @@ list(APPEND VNET_HEADERS
   ip/ip_packet.h
   ip/ip_source_and_port_range_check.h
   ip/ip_neighbor.h
+  ip/ip_types.h
   ip/lookup.h
   ip/ports.def
   ip/protocols.def
@@ -424,7 +510,11 @@ list(APPEND VNET_API_FILES
   ip/punt.api
 )
 
-list(APPEND VNET_MULTIARCH_SOURCES ip/ip4_forward.c ip/ip4_input.c)
+list(APPEND VNET_MULTIARCH_SOURCES
+  ip/ip4_forward.c
+  ip/ip6_forward.c
+  ip/ip4_input.c
+)
 
 ##############################################################################
 # Layer 2/3 ARP
@@ -460,6 +550,20 @@ list(APPEND VNET_SOURCES
 
 list(APPEND VNET_API_FILES bfd/bfd.api)
 
+##############################################################################
+# Crypto
+##############################################################################
+
+list(APPEND VNET_SOURCES
+  crypto/cli.c
+  crypto/crypto.c
+  crypto/format.c
+)
+
+list(APPEND VNET_HEADERS
+  crypto/crypto.h
+)
+
 ##############################################################################
 # Layer 3 protocol: IPSec
 ##############################################################################
@@ -468,21 +572,32 @@ list(APPEND VNET_SOURCES
   ipsec/ipsec_cli.c
   ipsec/ipsec_format.c
   ipsec/ipsec_input.c
-  ipsec/ipsec_if.c
-  ipsec/ipsec_if_in.c
+  ipsec/ipsec_punt.c
+  ipsec/ipsec_sa.c
+  ipsec/ipsec_spd.c
+  ipsec/ipsec_spd_policy.c
+  ipsec/ipsec_tun.c
+  ipsec/ipsec_tun_in.c
   ipsec/esp_format.c
   ipsec/esp_encrypt.c
   ipsec/esp_decrypt.c
   ipsec/ah_decrypt.c
   ipsec/ah_encrypt.c
-  ipsec/ikev2.c
-  ipsec/ikev2_crypto.c
-  ipsec/ikev2_cli.c
-  ipsec/ikev2_payload.c
-  ipsec/ikev2_format.c
   ipsec/ipsec_api.c
+  ipsec/ipsec_types_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  ipsec/esp_encrypt.c
+  ipsec/esp_decrypt.c
+  ipsec/ah_decrypt.c
+  ipsec/ah_encrypt.c
+  ipsec/ipsec_output.c
+  ipsec/ipsec_input.c
+  ipsec/ipsec_tun_in.c
+)
+
+list(APPEND VNET_API_FILES ipsec/ipsec_types.api)
 list(APPEND VNET_API_FILES ipsec/ipsec.api)
 
 list(APPEND VNET_SOURCES
@@ -491,10 +606,14 @@ list(APPEND VNET_SOURCES
 
 list(APPEND VNET_HEADERS
   ipsec/ipsec.h
+  ipsec/ipsec_spd.h
+  ipsec/ipsec_spd_policy.h
+  ipsec/ipsec_sa.h
+  ipsec/ipsec_tun.h
+  ipsec/ipsec_types_api.h
+  ipsec/ipsec_punt.h
   ipsec/esp.h
   ipsec/ah.h
-  ipsec/ikev2.h
-  ipsec/ikev2_priv.h
 )
 
 ##############################################################################
@@ -521,9 +640,18 @@ list(APPEND VNET_SOURCES
   tcp/tcp_output.c
   tcp/tcp_input.c
   tcp/tcp_newreno.c
+  tcp/tcp_cubic.c
+  tcp/tcp_bt.c
+  tcp/tcp_debug.c
   tcp/tcp.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  tcp/tcp_input.c
+  tcp/tcp_output.c
+  tcp/tcp_syn_filter4.c
+)
+
 list(APPEND VNET_HEADERS
   tcp/tcp_packet.h
   tcp/tcp_timer.h
@@ -548,6 +676,11 @@ list(APPEND VNET_SOURCES
   udp/udp_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  udp/udp_local.c
+  udp/udp_encap_node.c
+)
+
 list(APPEND VNET_HEADERS
   udp/udp_error.def
   udp/udp.h
@@ -556,27 +689,6 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES udp/udp.api)
 
-##############################################################################
-# Layer 4 protocol: sctp
-##############################################################################
-list(APPEND VNET_SOURCES
-  sctp/sctp_api.c
-  sctp/sctp.c
-  sctp/sctp_pg.c
-  sctp/sctp_input.c
-  sctp/sctp_output.c
-  sctp/sctp_format.c
-)
-
-list(APPEND VNET_HEADERS
-  sctp/sctp_error.def
-  sctp/sctp_packet.h
-  sctp/sctp_timer.h
-  sctp/sctp.h
-)
-
-list(APPEND VNET_API_FILES sctp/sctp.api)
-
 ##############################################################################
 # Tunnel protocol: gre
 ##############################################################################
@@ -588,6 +700,11 @@ list(APPEND VNET_SOURCES
   gre/gre_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  gre/node.c
+  gre/gre.c
+)
+
 list(APPEND VNET_HEADERS
   gre/gre.h
   gre/packet.h
@@ -605,13 +722,22 @@ list(APPEND VNET_SOURCES
   ipip/sixrd.c
   ipip/ipip_api.c
   ipip/ipip_cli.c
+  ipip/ipip_types_api.c
+)
+
+list(APPEND VNET_MULTIARCH_SOURCES
+  ipip/node.c
 )
 
 list(APPEND VNET_HEADERS
   ipip/ipip.h
+  ipip/ipip_types_api.h
 )
 
-list(APPEND VNET_API_FILES ipip/ipip.api)
+list(APPEND VNET_API_FILES
+  ipip/ipip_types.api
+  ipip/ipip.api
+)
 
 ##############################################################################
 # Tunnel protocol: l2tpv3
@@ -624,6 +750,11 @@ list(APPEND VNET_SOURCES
   l2tp/l2tp_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  l2tp/encap.c
+  l2tp/decap.c
+)
+
 list(APPEND VNET_HEADERS
   l2tp/l2tp.h
   l2tp/packet.h
@@ -646,6 +777,13 @@ list(APPEND VNET_SOURCES
   mpls/mpls_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  mpls/mpls_output.c
+  mpls/mpls_input.c
+  mpls/mpls_lookup.c
+  mpls/mpls_features.c
+)
+
 list(APPEND VNET_HEADERS
   mpls/mpls.h
   mpls/mpls_types.h
@@ -656,6 +794,30 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES mpls/mpls.api)
 
+##############################################################################
+# Tunnel protocol: vxlan-gbp
+##############################################################################
+list(APPEND VNET_SOURCES
+  vxlan-gbp/decap.c
+  vxlan-gbp/encap.c
+  vxlan-gbp/vxlan_gbp_api.c
+  vxlan-gbp/vxlan_gbp.c
+  vxlan-gbp/vxlan_gbp_packet.c
+)
+
+list (APPEND VNET_MULTIARCH_SOURCES
+  vxlan-gbp/decap.c
+  vxlan-gbp/encap.c
+)
+
+list(APPEND VNET_HEADERS
+  vxlan-gbp/vxlan_gbp.h
+  vxlan-gbp/vxlan_gbp_packet.h
+  vxlan-gbp/vxlan_gbp_error.def
+)
+
+list(APPEND VNET_API_FILES vxlan-gbp/vxlan_gbp.api)
+
 ##############################################################################
 # Tunnel protocol: vxlan-gpe
 ##############################################################################
@@ -667,6 +829,10 @@ list(APPEND VNET_SOURCES
   vxlan-gpe/vxlan_gpe_api.c
 )
 
+list (APPEND VNET_MULTIARCH_SOURCES
+  vxlan-gpe/decap.c
+)
+
 list(APPEND VNET_HEADERS
   vxlan-gpe/vxlan_gpe.h
   vxlan-gpe/vxlan_gpe_packet.h
@@ -675,23 +841,6 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES vxlan-gpe/vxlan_gpe.api)
 
-##############################################################################
-# Tunnel protocol: ipsec+gre
-##############################################################################
-list(APPEND VNET_SOURCES
-  ipsec-gre/ipsec_gre.c
-  ipsec-gre/node.c
-  ipsec-gre/interface.c
-  ipsec-gre/ipsec_gre_api.c
-)
-
-list(APPEND VNET_HEADERS
-  ipsec-gre/ipsec_gre.h
-  ipsec-gre/error.def
-)
-
-list(APPEND VNET_API_FILES ipsec-gre/ipsec_gre.api)
-
 ##############################################################################
 # LISP control plane: lisp-cp
 ##############################################################################
@@ -747,50 +896,6 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES lisp-gpe/lisp_gpe.api)
 
-##############################################################################
-# DHCP client
-##############################################################################
-list(APPEND VNET_SOURCES
-  dhcp/client.c
-  dhcp/dhcp_client_detect.c
-  dhcp/dhcp6_client_common_dp.c
-  dhcp/dhcp6_pd_client_dp.c
-  dhcp/dhcp6_pd_client_cp.c
-  dhcp/dhcp6_ia_na_client_dp.c
-  dhcp/dhcp6_ia_na_client_cp.c
-  dhcp/dhcp_api.c
-)
-
-list(APPEND VNET_HEADERS
-  dhcp/client.h
-  dhcp/dhcp6_client_common_dp.h
-  dhcp/dhcp6_pd_client_dp.h
-  dhcp/dhcp6_ia_na_client_dp.h
-)
-
-list(APPEND VNET_API_FILES
-  dhcp/dhcp.api
-  dhcp/dhcp6_pd_client_cp.api
-  dhcp/dhcp6_ia_na_client_cp.api
-)
-
-##############################################################################
-# DHCP proxy
-##############################################################################
-list(APPEND VNET_SOURCES
-  dhcp/dhcp6_proxy_node.c
-  dhcp/dhcp4_proxy_node.c
-  dhcp/dhcp_proxy.c
-)
-
-list(APPEND VNET_HEADERS
-  dhcp/dhcp4_packet.h
-  dhcp/dhcp6_packet.h
-  dhcp/dhcp_proxy.h
-  dhcp/dhcp6_proxy_error.def
-  dhcp/dhcp4_proxy_error.def
-)
-
 ##############################################################################
 # ipv6 segment routing
 ##############################################################################
@@ -842,6 +947,24 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES ipfix-export/ipfix_export.api)
 
+##############################################################################
+# GSO
+##############################################################################
+list(APPEND VNET_SOURCES
+  gso/cli.c
+  gso/gso.c
+  gso/gso_api.c
+  gso/node.c
+)
+
+list(APPEND VNET_HEADERS
+  gso/gso.h
+)
+
+list(APPEND VNET_API_FILES
+  gso/gso.api
+)
+
 ##############################################################################
 # IPFIX classify code
 ##############################################################################
@@ -863,6 +986,10 @@ list(APPEND VNET_SOURCES
   lawful-intercept/node.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  lawful-intercept/node.c
+)
+
 list(APPEND VNET_HEADERS
   lawful-intercept/lawful_intercept.h
 )
@@ -877,29 +1004,15 @@ list(APPEND VNET_SOURCES
   span/node.c
 )
 
-list(APPEND VNET_HEADERS
-  span/span.h
-)
-
-list(APPEND VNET_API_FILES span/span.api)
-
-##############################################################################
-# DNS proxy, API
-##############################################################################
-list(APPEND VNET_SOURCES
-  dns/dns.c
-  dns/dns.h
-  dns/dns_packet.h
-  dns/reply_node.c
-  dns/request_node.c
-  dns/resolver_process.c
+list(APPEND VNET_MULTIARCH_SOURCES
+  span/node.c
 )
 
 list(APPEND VNET_HEADERS
-  dns/dns.h
+  span/span.h
 )
 
-list(APPEND VNET_API_FILES dns/dns.api)
+list(APPEND VNET_API_FILES span/span.api)
 
 ##############################################################################
 # Packet generator
@@ -927,16 +1040,21 @@ list(APPEND VNET_API_FILES pg/pg.api)
 ##############################################################################
 
 list(APPEND VNET_SOURCES
+  devices/virtio/cli.c
   devices/virtio/device.c
+  devices/virtio/format.c
   devices/virtio/node.c
+  devices/virtio/pci.c
   devices/virtio/vhost_user.c
   devices/virtio/vhost_user_input.c
   devices/virtio/vhost_user_output.c
   devices/virtio/vhost_user_api.c
   devices/virtio/virtio.c
+  devices/virtio/virtio_api.c
 )
 
 list(APPEND VNET_HEADERS
+  devices/virtio/pci.h
   devices/virtio/virtio.h
   devices/virtio/vhost_user.h
 )
@@ -944,9 +1062,16 @@ list(APPEND VNET_HEADERS
 list(APPEND VNET_MULTIARCH_SOURCES
   devices/virtio/vhost_user_input.c
   devices/virtio/vhost_user_output.c
+  devices/netmap/node.c
+  devices/virtio/node.c
+  devices/af_packet/node.c
+  devices/virtio/device.c
 )
 
-list(APPEND VNET_API_FILES devices/virtio/vhost_user.api)
+list(APPEND VNET_API_FILES
+  devices/virtio/vhost_user.api
+  devices/virtio/virtio.api
+)
 
 ##############################################################################
 # tap interface (with virtio backend)
@@ -991,11 +1116,12 @@ list(APPEND VNET_SOURCES
   session/session_node.c
   session/transport.c
   session/application.c
+  session/application_worker.c
   session/session_cli.c
   session/application_interface.c
+  session/application_local.c
   session/application_namespace.c
   session/segment_manager.c
-  session/session_test.c
   session/session_api.c
 )
 
@@ -1003,12 +1129,13 @@ list(APPEND VNET_HEADERS
   session/session.h
   session/session_table.h
   session/session_rules_table.h
-  session/stream_session.h
+  session/session_types.h
   session/session_lookup.h
   session/application.h
   session/transport.h
-  session/transport_interface.h
+  session/transport_types.h
   session/application_interface.h
+  session/application_local.h
   session/application_namespace.h
   session/session_debug.h
   session/segment_manager.h
@@ -1020,22 +1147,6 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES session/session.api)
 
-##############################################################################
-# session layer applications
-##############################################################################
-
-list(APPEND VNET_SOURCES
-  session-apps/echo_client.c
-  session-apps/echo_server.c
-  session-apps/http_server.c
-  session-apps/proxy.c
-)
-
-list(APPEND VNET_HEADERS
-  session-apps/echo_client.h
-  session-apps/proxy.h
-)
-
 ##############################################################################
 # TLS protocol
 ##############################################################################
@@ -1046,6 +1157,7 @@ list(APPEND VNET_SOURCES
 
 list(APPEND VNET_HEADERS
   tls/tls.h
+  tls/tls_test.h
 )
 
 ##############################################################################
@@ -1060,6 +1172,11 @@ list(APPEND VNET_SOURCES
   devices/af_packet/af_packet_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  devices/netmap/device.c
+  devices/af_packet/device.c
+)
+
 list(APPEND VNET_HEADERS
   devices/af_packet/af_packet.h
 )
@@ -1108,27 +1225,19 @@ list(APPEND VNET_API_FILES feature/feature.api)
 
 list(APPEND VNET_SOURCES
   unix/gdb_funcs.c
-  unix/pcap.c
-  unix/tap_api.c
-  unix/tapcli.c
   unix/tuntap.c
 )
 
 list(APPEND VNET_HEADERS
-  unix/pcap.h
   unix/tuntap.h
-  unix/tapcli.h
 )
 
-list(APPEND VNET_API_FILES unix/tap.api)
-
 ##############################################################################
 # FIB
 ##############################################################################
 
 list(APPEND VNET_SOURCES
   fib/fib.c
-  fib/fib_test.c
   fib/ip4_fib.c
   fib/ip6_fib.c
   fib/mpls_fib.c
@@ -1150,6 +1259,7 @@ list(APPEND VNET_SOURCES
   fib/fib_entry_src_lisp.c
   fib/fib_entry_cover.c
   fib/fib_entry_delegate.c
+  fib/fib_entry_track.c
   fib/fib_path_list.c
   fib/fib_path.c
   fib/fib_path_ext.c
@@ -1172,6 +1282,8 @@ list(APPEND VNET_HEADERS
   fib/fib_entry_delegate.h
 )
 
+list(APPEND VNET_API_FILES fib/fib_types.api)
+
 ##############################################################################
 # ADJ
 ##############################################################################
@@ -1180,6 +1292,7 @@ list(APPEND VNET_SOURCES
   adj/adj_nbr.c
   adj/adj_glean.c
   adj/adj_midchain.c
+  adj/adj_midchain_delegate.c
   adj/adj_mcast.c
   adj/adj_l2.c
   adj/adj_nsh.c
@@ -1189,12 +1302,18 @@ list(APPEND VNET_SOURCES
   adj/adj_delegate.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  adj/adj_nsh.c
+  adj/adj_l2.c
+)
+
 list(APPEND VNET_HEADERS
   adj/adj.h
   adj/adj_types.h
   adj/adj_glean.h
   adj/adj_nsh.h
   adj/adj_nbr.h
+  adj/adj_midchain.h
   adj/rewrite.h
 )
 
@@ -1220,6 +1339,15 @@ list(APPEND VNET_SOURCES
   dpo/mpls_label_dpo.c
   dpo/l3_proxy_dpo.c
   dpo/dvr_dpo.c
+  dpo/pw_cw.c
+)
+
+list(APPEND VNET_MULTIARCH_SOURCES
+  dpo/lookup_dpo.h
+  dpo/mpls_disposition.c
+  dpo/dvr_dpo.c
+  dpo/mpls_label_dpo.c
+  dpo/interface_rx_dpo.c
 )
 
 list(APPEND VNET_HEADERS
@@ -1239,23 +1367,34 @@ list(APPEND VNET_HEADERS
 ##############################################################################
 
 list(APPEND VNET_SOURCES
-  mfib/mfib_test.c
   mfib/mfib_forward.c
   mfib/ip4_mfib.c
   mfib/ip6_mfib.c
+  mfib/mfib_api.c
   mfib/mfib_types.c
   mfib/mfib_signal.c
   mfib/mfib_itf.c
   mfib/mfib_entry.c
+  mfib/mfib_entry.c
+  mfib/mfib_entry_cover.c
+  mfib/mfib_entry_delegate.c
+  mfib/mfib_entry_src.c
+  mfib/mfib_entry_src_rr.c
   mfib/mfib_table.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  mfib/mfib_forward.c
+)
+
 list(APPEND VNET_HEADERS
   mfib/ip4_mfib.h
   mfib/mfib_types.h
   mfib/mfib_table.h
 )
 
+list(APPEND VNET_API_FILES mfib/mfib_types.api)
+
 ##############################################################################
 # Utilities
 ##############################################################################
@@ -1280,7 +1419,16 @@ list(APPEND VNET_SOURCES
   qos/qos_api.c
   qos/qos_egress_map.c
   qos/qos_record.c
+  qos/qos_record_node.c
+  qos/qos_store.c
+  qos/qos_store_node.c
   qos/qos_mark.c
+  qos/qos_mark_node.c
+)
+
+list(APPEND VNET_MULTIARCH_SOURCES
+  qos/qos_record_node.c
+  qos/qos_mark_node.c
 )
 
 list(APPEND VNET_API_FILES qos/qos.api)
@@ -1299,7 +1447,6 @@ list(APPEND VNET_SOURCES
   bier/bier_output.c
   bier/bier_table.c
   bier/bier_types.c
-  bier/bier_test.c
   bier/bier_api.c
   bier/bier_drop.c
   bier/bier_update.c
@@ -1312,6 +1459,12 @@ list(APPEND VNET_SOURCES
   bier/bier_bift_table.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  bier/bier_disp_dispatch_node.c
+  bier/bier_disp_lookup_node.c
+  bier/bier_imp_node.c
+)
+
 list(APPEND VNET_HEADERS
   bier/bier_types.h
   bier/bier_entry.h
@@ -1321,6 +1474,27 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES bier/bier.api)
 
+##############################################################################
+# SYSLOG
+##############################################################################
+
+list (APPEND VNET_SOURCES
+  syslog/syslog_api.c
+  syslog/syslog_udp.c
+  syslog/syslog.c
+)
+
+list(APPEND VNET_HEADERS
+  syslog/syslog_udp.h
+  syslog/syslog.h
+)
+
+list(APPEND VNET_API_FILES syslog/syslog.api)
+
+##############################################################################
+# VNET Library
+##############################################################################
+
 add_vpp_library(vnet
   SOURCES ${VNET_SOURCES}
   MULTIARCH_SOURCES ${VNET_MULTIARCH_SOURCES}
@@ -1329,3 +1503,5 @@ add_vpp_library(vnet
   LINK_LIBRARIES vppinfra svm vlib ${OPENSSL_LIBRARIES}
   DEPENDS api_headers
 )
+
+##############################################################################