hash: add support for hashing infra
[vpp.git] / src / vnet / CMakeLists.txt
index 78a2ba7..6813330 100644 (file)
@@ -881,6 +881,19 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES ipfix-export/ipfix_export.api)
 
+##############################################################################
+# HASH
+##############################################################################
+list(APPEND VNET_SOURCES
+  hash/hash.c
+  hash/cli.c
+  hash/crc32_5tuple.c
+)
+
+list(APPEND VNET_HEADERS
+  hash/hash.h
+)
+
 ##############################################################################
 # GSO
 ##############################################################################