deprecate tapcli
[vpp.git] / src / vnet / CMakeLists.txt
index a10ec82..a595df2 100644 (file)
@@ -37,7 +37,6 @@ list(APPEND VNET_SOURCES
   interface_output.c
   interface_stats.c
   misc.c
-  replication.c
 )
 
 list(APPEND VNET_HEADERS
@@ -56,7 +55,6 @@ list(APPEND VNET_HEADERS
   l3_types.h
   plugin/plugin.h
   pipeline.h
-  replication.h
   vnet.h
   vnet_all_api_h.h
   vnet_msg_enum.h
@@ -109,9 +107,11 @@ list(APPEND VNET_API_FILES cop/cop.api)
 # Layer 2 protocol: Ethernet
 ##############################################################################
 list(APPEND VNET_SOURCES
+  ethernet/ethernet_types_api.c
   ethernet/format.c
   ethernet/init.c
   ethernet/interface.c
+  ethernet/mac_address.c
   ethernet/node.c
   ethernet/pg.c
   ethernet/sfp.c
@@ -120,11 +120,12 @@ list(APPEND VNET_SOURCES
   ethernet/p2p_ethernet_api.c
 )
 
-list(APPEND VNET_MULTIARCH_SOURCES l2/l2_output.c)
+list(APPEND VNET_MULTIARCH_SOURCES ethernet/node.c)
 
 list(APPEND VNET_HEADERS
   ethernet/error.def
   ethernet/ethernet.h
+  ethernet/mac_address.h
   ethernet/packet.h
   ethernet/types.def
   ethernet/sfp.h
@@ -152,12 +153,21 @@ list(APPEND VNET_SOURCES
   l2/l2_learn.c
   l2/l2_output.c
   l2/l2_in_out_acl.c
+  l2/l2_in_out_feat_arc.c
   l2/l2_patch.c
   l2/l2_rw.c
+  l2/l2_uu_fwd.c
   l2/l2_vtr.c
   l2/l2_xcrw.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  l2/l2_fwd.c
+  l2/l2_learn.c
+  l2/l2_output.c
+  l2/l2_patch.c
+)
+
 list(APPEND VNET_HEADERS
   l2/feat_bitmap.h
   l2/l2_input.h
@@ -300,7 +310,7 @@ list(APPEND VNET_HEADERS
   bonding/node.h
 )
 
-list(APPEND VNET_MULTIARCH_SOURCES bonding/node.c)
+list(APPEND VNET_MULTIARCH_SOURCES bonding/node.c bonding/device.c)
 list(APPEND VNET_API_FILES bonding/bond.api)
 
 ##############################################################################
@@ -483,6 +493,13 @@ list(APPEND VNET_SOURCES
   ipsec/ipsec_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  ipsec/esp_encrypt.c
+  ipsec/esp_decrypt.c
+  ipsec/ah_decrypt.c
+  ipsec/ah_encrypt.c
+)
+
 list(APPEND VNET_API_FILES ipsec/ipsec.api)
 
 list(APPEND VNET_SOURCES
@@ -521,6 +538,7 @@ list(APPEND VNET_SOURCES
   tcp/tcp_output.c
   tcp/tcp_input.c
   tcp/tcp_newreno.c
+  tcp/tcp_cubic.c
   tcp/tcp.c
 )
 
@@ -656,6 +674,25 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES mpls/mpls.api)
 
+##############################################################################
+# Tunnel protocol: vxlan-gbp
+##############################################################################
+list(APPEND VNET_SOURCES
+  vxlan-gbp/decap.c
+  vxlan-gbp/encap.c
+  vxlan-gbp/vxlan_gbp_api.c
+  vxlan-gbp/vxlan_gbp.c
+  vxlan-gbp/vxlan_gbp_packet.c
+)
+
+list(APPEND VNET_HEADERS
+  vxlan-gbp/vxlan_gbp.h
+  vxlan-gbp/vxlan_gbp_packet.h
+  vxlan-gbp/vxlan_gbp_error.def
+)
+
+list(APPEND VNET_API_FILES vxlan-gbp/vxlan_gbp.api)
+
 ##############################################################################
 # Tunnel protocol: vxlan-gpe
 ##############################################################################
@@ -934,9 +971,13 @@ list(APPEND VNET_SOURCES
   devices/virtio/vhost_user_output.c
   devices/virtio/vhost_user_api.c
   devices/virtio/virtio.c
+  devices/virtio/virtio_api.c
+  devices/virtio/cli.c
+  devices/virtio/pci.c
 )
 
 list(APPEND VNET_HEADERS
+  devices/virtio/pci.h
   devices/virtio/virtio.h
   devices/virtio/vhost_user.h
 )
@@ -946,7 +987,10 @@ list(APPEND VNET_MULTIARCH_SOURCES
   devices/virtio/vhost_user_output.c
 )
 
-list(APPEND VNET_API_FILES devices/virtio/vhost_user.api)
+list(APPEND VNET_API_FILES
+  devices/virtio/vhost_user.api
+  devices/virtio/virtio.api
+)
 
 ##############################################################################
 # tap interface (with virtio backend)
@@ -995,7 +1039,6 @@ list(APPEND VNET_SOURCES
   session/application_interface.c
   session/application_namespace.c
   session/segment_manager.c
-  session/session_test.c
   session/session_api.c
 )
 
@@ -1108,27 +1151,19 @@ list(APPEND VNET_API_FILES feature/feature.api)
 
 list(APPEND VNET_SOURCES
   unix/gdb_funcs.c
-  unix/pcap.c
-  unix/tap_api.c
-  unix/tapcli.c
   unix/tuntap.c
 )
 
 list(APPEND VNET_HEADERS
-  unix/pcap.h
   unix/tuntap.h
-  unix/tapcli.h
 )
 
-list(APPEND VNET_API_FILES unix/tap.api)
-
 ##############################################################################
 # FIB
 ##############################################################################
 
 list(APPEND VNET_SOURCES
   fib/fib.c
-  fib/fib_test.c
   fib/ip4_fib.c
   fib/ip6_fib.c
   fib/mpls_fib.c
@@ -1239,7 +1274,6 @@ list(APPEND VNET_HEADERS
 ##############################################################################
 
 list(APPEND VNET_SOURCES
-  mfib/mfib_test.c
   mfib/mfib_forward.c
   mfib/ip4_mfib.c
   mfib/ip6_mfib.c
@@ -1247,6 +1281,11 @@ list(APPEND VNET_SOURCES
   mfib/mfib_signal.c
   mfib/mfib_itf.c
   mfib/mfib_entry.c
+  mfib/mfib_entry.c
+  mfib/mfib_entry_cover.c
+  mfib/mfib_entry_delegate.c
+  mfib/mfib_entry_src.c
+  mfib/mfib_entry_src_rr.c
   mfib/mfib_table.c
 )
 
@@ -1299,7 +1338,6 @@ list(APPEND VNET_SOURCES
   bier/bier_output.c
   bier/bier_table.c
   bier/bier_types.c
-  bier/bier_test.c
   bier/bier_api.c
   bier/bier_drop.c
   bier/bier_update.c
@@ -1321,6 +1359,27 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES bier/bier.api)
 
+##############################################################################
+# SYSLOG
+##############################################################################
+
+list (APPEND VNET_SOURCES
+  syslog/syslog_api.c
+  syslog/syslog_udp.c
+  syslog/syslog.c
+)
+
+list(APPEND VNET_HEADERS
+  syslog/syslog_udp.h
+  syslog/syslog.h
+)
+
+list(APPEND VNET_API_FILES syslog/syslog.api)
+
+##############################################################################
+# VNET Library
+##############################################################################
+
 add_vpp_library(vnet
   SOURCES ${VNET_SOURCES}
   MULTIARCH_SOURCES ${VNET_MULTIARCH_SOURCES}
@@ -1329,3 +1388,25 @@ add_vpp_library(vnet
   LINK_LIBRARIES vppinfra svm vlib ${OPENSSL_LIBRARIES}
   DEPENDS api_headers
 )
+
+##############################################################################
+# Session echo apps
+##############################################################################
+
+option(VPP_BUILD_SESSION_ECHO_APPS "Build session echo apps." ON)
+if(VPP_BUILD_SESSION_ECHO_APPS)
+  add_vpp_executable(tcp_echo
+    SOURCES ../tests/vnet/session/tcp_echo.c
+    LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
+    DEPENDS api_headers
+    NO_INSTALL
+    )
+  add_vpp_executable(udp_echo
+    SOURCES ../tests/vnet/session/udp_echo.c
+    LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
+    DEPENDS api_headers
+    NO_INSTALL
+    )
+endif(VPP_BUILD_SESSION_ECHO_APPS)
+
+##############################################################################