Punt: socket register for exception dispatched/punted packets based on reason
[vpp.git] / src / vnet / CMakeLists.txt
index 5bac7db..dcbdb73 100644 (file)
@@ -39,6 +39,12 @@ list(APPEND VNET_SOURCES
   misc.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  interface_output.c
+  interface_stats.c
+  handoff.c
+)
+
 list(APPEND VNET_HEADERS
   api_errno.h
   buffer.h
@@ -52,6 +58,7 @@ list(APPEND VNET_HEADERS
   interface_funcs.h
   ip/ip4_to_ip6.h
   ip/ip6_to_ip4.h
+  ip/ip_types_api.h
   l3_types.h
   plugin/plugin.h
   pipeline.h
@@ -62,7 +69,10 @@ list(APPEND VNET_HEADERS
   util/refcount.h
 )
 
-list(APPEND VNET_API_FILES interface.api)
+list(APPEND VNET_API_FILES
+  interface.api
+  ip/ip_types.api
+)
 
 ##############################################################################
 # Policer infra
@@ -74,6 +84,10 @@ list(APPEND VNET_SOURCES
   policer/policer_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  policer/node_funcs.c
+)
+
 list(APPEND VNET_HEADERS
   policer/police.h
   policer/policer.h
@@ -93,6 +107,12 @@ list(APPEND VNET_SOURCES
   cop/cop_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  cop/node1.c
+  cop/ip4_whitelist.c
+  cop/ip6_whitelist.c
+)
+
 list(APPEND VNET_HEADERS
   cop/cop.h
 )
@@ -120,11 +140,15 @@ list(APPEND VNET_SOURCES
   ethernet/p2p_ethernet_api.c
 )
 
-list(APPEND VNET_MULTIARCH_SOURCES ethernet/node.c)
+list(APPEND VNET_MULTIARCH_SOURCES
+  ethernet/node.c
+  ethernet/p2p_ethernet_input.c
+)
 
 list(APPEND VNET_HEADERS
   ethernet/error.def
   ethernet/ethernet.h
+  ethernet/mac_address.h
   ethernet/packet.h
   ethernet/types.def
   ethernet/sfp.h
@@ -141,6 +165,7 @@ list(APPEND VNET_SOURCES
   l2/l2_api.c
   l2/l2_bd.c
   l2/l2_bvi.c
+  l2/l2_bvi_node.c
   l2/l2_input_classify.c
   l2/l2_output_classify.c
   l2/l2_efp_filter.c
@@ -161,9 +186,22 @@ list(APPEND VNET_SOURCES
 )
 
 list(APPEND VNET_MULTIARCH_SOURCES
+  l2/l2_bvi_node.c
   l2/l2_fwd.c
   l2/l2_learn.c
   l2/l2_output.c
+  l2/l2_patch.c
+  l2/l2_in_out_feat_arc.c
+  l2/l2_input_classify.c
+  l2/l2_input.c
+  l2/l2_output_classify.c
+  l2/l2_flood.c
+  l2/l2_uu_fwd.c
+  l2/l2_efp_filter.c
+  l2/l2_rw.c
+  l2/l2_xcrw.c
+  l2/l2_in_out_acl.c
+  l2/l2_input_vtr.c
 )
 
 list(APPEND VNET_HEADERS
@@ -266,6 +304,10 @@ list(APPEND VNET_SOURCES
   vxlan/vxlan_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  vxlan/encap.c
+)
+
 list(APPEND VNET_HEADERS
   vxlan/vxlan.h
   vxlan/vxlan_packet.h
@@ -286,6 +328,11 @@ list(APPEND VNET_SOURCES
   geneve/geneve_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  geneve/encap.c
+  geneve/decap.c
+)
+
 list(APPEND VNET_HEADERS
   geneve/geneve.h
   geneve/geneve_packet.h
@@ -343,6 +390,11 @@ list(APPEND VNET_SOURCES
   classify/classify_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  classify/ip_classify.c
+  classify/flow_classify_node.c
+)
+
 list(APPEND VNET_HEADERS
   classify/vnet_classify.h
   classify/in_out_acl.h
@@ -397,6 +449,19 @@ list(APPEND VNET_SOURCES
   ip/ping.c
   ip/punt_api.c
   ip/punt.c
+  ip/punt_node.c
+)
+
+list(APPEND VNET_MULTIARCH_SOURCES
+  ip/ip4_source_check.c
+  ip/ip4_punt_drop.c
+  ip/ip4_reassembly.c
+  ip/ip6_hop_by_hop.c
+  ip/ip6_reassembly.c
+  ip/ip6_input.c
+  ip/ip6_punt_drop.c
+  ip/punt_node.c
+  ip/ip_in_out_acl.c
 )
 
 list(APPEND VNET_HEADERS
@@ -432,7 +497,11 @@ list(APPEND VNET_API_FILES
   ip/punt.api
 )
 
-list(APPEND VNET_MULTIARCH_SOURCES ip/ip4_forward.c ip/ip4_input.c)
+list(APPEND VNET_MULTIARCH_SOURCES
+  ip/ip4_forward.c
+  ip/ip6_forward.c
+  ip/ip4_input.c
+)
 
 ##############################################################################
 # Layer 2/3 ARP
@@ -468,6 +537,20 @@ list(APPEND VNET_SOURCES
 
 list(APPEND VNET_API_FILES bfd/bfd.api)
 
+##############################################################################
+# Crypto
+##############################################################################
+
+list(APPEND VNET_SOURCES
+  crypto/cli.c
+  crypto/crypto.c
+  crypto/format.c
+)
+
+list(APPEND VNET_HEADERS
+  crypto/crypto.h
+)
+
 ##############################################################################
 # Layer 3 protocol: IPSec
 ##############################################################################
@@ -478,19 +561,28 @@ list(APPEND VNET_SOURCES
   ipsec/ipsec_input.c
   ipsec/ipsec_if.c
   ipsec/ipsec_if_in.c
+  ipsec/ipsec_punt.c
+  ipsec/ipsec_sa.c
+  ipsec/ipsec_spd.c
+  ipsec/ipsec_spd_policy.c
   ipsec/esp_format.c
   ipsec/esp_encrypt.c
   ipsec/esp_decrypt.c
   ipsec/ah_decrypt.c
   ipsec/ah_encrypt.c
-  ipsec/ikev2.c
-  ipsec/ikev2_crypto.c
-  ipsec/ikev2_cli.c
-  ipsec/ikev2_payload.c
-  ipsec/ikev2_format.c
   ipsec/ipsec_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  ipsec/esp_encrypt.c
+  ipsec/esp_decrypt.c
+  ipsec/ah_decrypt.c
+  ipsec/ah_encrypt.c
+  ipsec/ipsec_if_in.c
+  ipsec/ipsec_output.c
+  ipsec/ipsec_input.c
+)
+
 list(APPEND VNET_API_FILES ipsec/ipsec.api)
 
 list(APPEND VNET_SOURCES
@@ -499,10 +591,12 @@ list(APPEND VNET_SOURCES
 
 list(APPEND VNET_HEADERS
   ipsec/ipsec.h
+  ipsec/ipsec_spd.h
+  ipsec/ipsec_spd_policy.h
+  ipsec/ipsec_sa.h
+  ipsec/ipsec_if.h
   ipsec/esp.h
   ipsec/ah.h
-  ipsec/ikev2.h
-  ipsec/ikev2_priv.h
 )
 
 ##############################################################################
@@ -529,9 +623,16 @@ list(APPEND VNET_SOURCES
   tcp/tcp_output.c
   tcp/tcp_input.c
   tcp/tcp_newreno.c
+  tcp/tcp_cubic.c
   tcp/tcp.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  tcp/tcp_input.c
+  tcp/tcp_output.c
+  tcp/tcp_syn_filter4.c
+)
+
 list(APPEND VNET_HEADERS
   tcp/tcp_packet.h
   tcp/tcp_timer.h
@@ -556,6 +657,11 @@ list(APPEND VNET_SOURCES
   udp/udp_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  udp/udp_local.c
+  udp/udp_encap_node.c
+)
+
 list(APPEND VNET_HEADERS
   udp/udp_error.def
   udp/udp.h
@@ -573,9 +679,15 @@ list(APPEND VNET_SOURCES
   sctp/sctp_pg.c
   sctp/sctp_input.c
   sctp/sctp_output.c
+  sctp/sctp_output_node.c
   sctp/sctp_format.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  sctp/sctp_output_node.c
+  sctp/sctp_input.c
+)
+
 list(APPEND VNET_HEADERS
   sctp/sctp_error.def
   sctp/sctp_packet.h
@@ -596,6 +708,11 @@ list(APPEND VNET_SOURCES
   gre/gre_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  gre/node.c
+  gre/gre.c
+)
+
 list(APPEND VNET_HEADERS
   gre/gre.h
   gre/packet.h
@@ -615,6 +732,10 @@ list(APPEND VNET_SOURCES
   ipip/ipip_cli.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  ipip/node.c
+)
+
 list(APPEND VNET_HEADERS
   ipip/ipip.h
 )
@@ -632,6 +753,11 @@ list(APPEND VNET_SOURCES
   l2tp/l2tp_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  l2tp/encap.c
+  l2tp/decap.c
+)
+
 list(APPEND VNET_HEADERS
   l2tp/l2tp.h
   l2tp/packet.h
@@ -654,6 +780,13 @@ list(APPEND VNET_SOURCES
   mpls/mpls_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  mpls/mpls_output.c
+  mpls/mpls_input.c
+  mpls/mpls_lookup.c
+  mpls/mpls_features.c
+)
+
 list(APPEND VNET_HEADERS
   mpls/mpls.h
   mpls/mpls_types.h
@@ -672,6 +805,12 @@ list(APPEND VNET_SOURCES
   vxlan-gbp/encap.c
   vxlan-gbp/vxlan_gbp_api.c
   vxlan-gbp/vxlan_gbp.c
+  vxlan-gbp/vxlan_gbp_packet.c
+)
+
+list (APPEND VNET_MULTIARCH_SOURCES
+  vxlan-gbp/decap.c
+  vxlan-gbp/encap.c
 )
 
 list(APPEND VNET_HEADERS
@@ -693,6 +832,10 @@ list(APPEND VNET_SOURCES
   vxlan-gpe/vxlan_gpe_api.c
 )
 
+list (APPEND VNET_MULTIARCH_SOURCES
+  vxlan-gpe/decap.c
+)
+
 list(APPEND VNET_HEADERS
   vxlan-gpe/vxlan_gpe.h
   vxlan-gpe/vxlan_gpe_packet.h
@@ -711,6 +854,11 @@ list(APPEND VNET_SOURCES
   ipsec-gre/ipsec_gre_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  ipsec-gre/node.c
+  ipsec-gre/ipsec_gre.c
+)
+
 list(APPEND VNET_HEADERS
   ipsec-gre/ipsec_gre.h
   ipsec-gre/error.def
@@ -787,6 +935,10 @@ list(APPEND VNET_SOURCES
   dhcp/dhcp_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  dhcp/dhcp_client_detect.c
+)
+
 list(APPEND VNET_HEADERS
   dhcp/client.h
   dhcp/dhcp6_client_common_dp.h
@@ -889,6 +1041,10 @@ list(APPEND VNET_SOURCES
   lawful-intercept/node.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  lawful-intercept/node.c
+)
+
 list(APPEND VNET_HEADERS
   lawful-intercept/lawful_intercept.h
 )
@@ -903,6 +1059,10 @@ list(APPEND VNET_SOURCES
   span/node.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  span/node.c
+)
+
 list(APPEND VNET_HEADERS
   span/span.h
 )
@@ -960,9 +1120,13 @@ list(APPEND VNET_SOURCES
   devices/virtio/vhost_user_output.c
   devices/virtio/vhost_user_api.c
   devices/virtio/virtio.c
+  devices/virtio/virtio_api.c
+  devices/virtio/cli.c
+  devices/virtio/pci.c
 )
 
 list(APPEND VNET_HEADERS
+  devices/virtio/pci.h
   devices/virtio/virtio.h
   devices/virtio/vhost_user.h
 )
@@ -970,9 +1134,16 @@ list(APPEND VNET_HEADERS
 list(APPEND VNET_MULTIARCH_SOURCES
   devices/virtio/vhost_user_input.c
   devices/virtio/vhost_user_output.c
+  devices/netmap/node.c
+  devices/virtio/node.c
+  devices/af_packet/node.c
+  devices/virtio/device.c
 )
 
-list(APPEND VNET_API_FILES devices/virtio/vhost_user.api)
+list(APPEND VNET_API_FILES
+  devices/virtio/vhost_user.api
+  devices/virtio/virtio.api
+)
 
 ##############################################################################
 # tap interface (with virtio backend)
@@ -1017,8 +1188,10 @@ list(APPEND VNET_SOURCES
   session/session_node.c
   session/transport.c
   session/application.c
+  session/application_worker.c
   session/session_cli.c
   session/application_interface.c
+  session/application_local.c
   session/application_namespace.c
   session/segment_manager.c
   session/session_api.c
@@ -1028,12 +1201,13 @@ list(APPEND VNET_HEADERS
   session/session.h
   session/session_table.h
   session/session_rules_table.h
-  session/stream_session.h
+  session/session_types.h
   session/session_lookup.h
   session/application.h
   session/transport.h
-  session/transport_interface.h
+  session/transport_types.h
   session/application_interface.h
+  session/application_local.h
   session/application_namespace.h
   session/session_debug.h
   session/segment_manager.h
@@ -1071,6 +1245,7 @@ list(APPEND VNET_SOURCES
 
 list(APPEND VNET_HEADERS
   tls/tls.h
+  tls/tls_test.h
 )
 
 ##############################################################################
@@ -1085,6 +1260,11 @@ list(APPEND VNET_SOURCES
   devices/af_packet/af_packet_api.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  devices/netmap/device.c
+  devices/af_packet/device.c
+)
+
 list(APPEND VNET_HEADERS
   devices/af_packet/af_packet.h
 )
@@ -1133,27 +1313,19 @@ list(APPEND VNET_API_FILES feature/feature.api)
 
 list(APPEND VNET_SOURCES
   unix/gdb_funcs.c
-  unix/pcap.c
-  unix/tap_api.c
-  unix/tapcli.c
   unix/tuntap.c
 )
 
 list(APPEND VNET_HEADERS
-  unix/pcap.h
   unix/tuntap.h
-  unix/tapcli.h
 )
 
-list(APPEND VNET_API_FILES unix/tap.api)
-
 ##############################################################################
 # FIB
 ##############################################################################
 
 list(APPEND VNET_SOURCES
   fib/fib.c
-  fib/fib_test.c
   fib/ip4_fib.c
   fib/ip6_fib.c
   fib/mpls_fib.c
@@ -1205,6 +1377,7 @@ list(APPEND VNET_SOURCES
   adj/adj_nbr.c
   adj/adj_glean.c
   adj/adj_midchain.c
+  adj/adj_midchain_delegate.c
   adj/adj_mcast.c
   adj/adj_l2.c
   adj/adj_nsh.c
@@ -1214,6 +1387,11 @@ list(APPEND VNET_SOURCES
   adj/adj_delegate.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  adj/adj_nsh.c
+  adj/adj_l2.c
+)
+
 list(APPEND VNET_HEADERS
   adj/adj.h
   adj/adj_types.h
@@ -1247,6 +1425,14 @@ list(APPEND VNET_SOURCES
   dpo/dvr_dpo.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  dpo/lookup_dpo.h
+  dpo/mpls_disposition.c
+  dpo/dvr_dpo.c
+  dpo/mpls_label_dpo.c
+  dpo/interface_rx_dpo.c
+)
+
 list(APPEND VNET_HEADERS
   dpo/load_balance.h
   dpo/drop_dpo.h
@@ -1264,7 +1450,6 @@ list(APPEND VNET_HEADERS
 ##############################################################################
 
 list(APPEND VNET_SOURCES
-  mfib/mfib_test.c
   mfib/mfib_forward.c
   mfib/ip4_mfib.c
   mfib/ip6_mfib.c
@@ -1272,9 +1457,18 @@ list(APPEND VNET_SOURCES
   mfib/mfib_signal.c
   mfib/mfib_itf.c
   mfib/mfib_entry.c
+  mfib/mfib_entry.c
+  mfib/mfib_entry_cover.c
+  mfib/mfib_entry_delegate.c
+  mfib/mfib_entry_src.c
+  mfib/mfib_entry_src_rr.c
   mfib/mfib_table.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  mfib/mfib_forward.c
+)
+
 list(APPEND VNET_HEADERS
   mfib/ip4_mfib.h
   mfib/mfib_types.h
@@ -1305,7 +1499,14 @@ list(APPEND VNET_SOURCES
   qos/qos_api.c
   qos/qos_egress_map.c
   qos/qos_record.c
+  qos/qos_record_node.c
   qos/qos_mark.c
+  qos/qos_mark_node.c
+)
+
+list(APPEND VNET_MULTIARCH_SOURCES
+  qos/qos_record_node.c
+  qos/qos_mark_node.c
 )
 
 list(APPEND VNET_API_FILES qos/qos.api)
@@ -1324,7 +1525,6 @@ list(APPEND VNET_SOURCES
   bier/bier_output.c
   bier/bier_table.c
   bier/bier_types.c
-  bier/bier_test.c
   bier/bier_api.c
   bier/bier_drop.c
   bier/bier_update.c
@@ -1337,6 +1537,12 @@ list(APPEND VNET_SOURCES
   bier/bier_bift_table.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES
+  bier/bier_disp_dispatch_node.c
+  bier/bier_disp_lookup_node.c
+  bier/bier_imp_node.c
+)
+
 list(APPEND VNET_HEADERS
   bier/bier_types.h
   bier/bier_entry.h
@@ -1346,6 +1552,23 @@ list(APPEND VNET_HEADERS
 
 list(APPEND VNET_API_FILES bier/bier.api)
 
+##############################################################################
+# SYSLOG
+##############################################################################
+
+list (APPEND VNET_SOURCES
+  syslog/syslog_api.c
+  syslog/syslog_udp.c
+  syslog/syslog.c
+)
+
+list(APPEND VNET_HEADERS
+  syslog/syslog_udp.h
+  syslog/syslog.h
+)
+
+list(APPEND VNET_API_FILES syslog/syslog.api)
+
 ##############################################################################
 # VNET Library
 ##############################################################################
@@ -1371,6 +1594,12 @@ if(VPP_BUILD_SESSION_ECHO_APPS)
     DEPENDS api_headers
     NO_INSTALL
     )
+  add_vpp_executable(quic_echo
+    SOURCES ../tests/vnet/session/quic_echo.c
+    LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
+    DEPENDS api_headers
+    NO_INSTALL
+    )
   add_vpp_executable(udp_echo
     SOURCES ../tests/vnet/session/udp_echo.c
     LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt