Punt: socket register for exception dispatched/punted packets based on reason
[vpp.git] / src / vnet / CMakeLists.txt
index 8e56ac3..dcbdb73 100644 (file)
@@ -58,6 +58,7 @@ list(APPEND VNET_HEADERS
   interface_funcs.h
   ip/ip4_to_ip6.h
   ip/ip6_to_ip4.h
+  ip/ip_types_api.h
   l3_types.h
   plugin/plugin.h
   pipeline.h
@@ -68,7 +69,10 @@ list(APPEND VNET_HEADERS
   util/refcount.h
 )
 
-list(APPEND VNET_API_FILES interface.api)
+list(APPEND VNET_API_FILES
+  interface.api
+  ip/ip_types.api
+)
 
 ##############################################################################
 # Policer infra
@@ -445,6 +449,7 @@ list(APPEND VNET_SOURCES
   ip/ping.c
   ip/punt_api.c
   ip/punt.c
+  ip/punt_node.c
 )
 
 list(APPEND VNET_MULTIARCH_SOURCES
@@ -455,7 +460,7 @@ list(APPEND VNET_MULTIARCH_SOURCES
   ip/ip6_reassembly.c
   ip/ip6_input.c
   ip/ip6_punt_drop.c
-  ip/punt.c
+  ip/punt_node.c
   ip/ip_in_out_acl.c
 )
 
@@ -556,6 +561,7 @@ list(APPEND VNET_SOURCES
   ipsec/ipsec_input.c
   ipsec/ipsec_if.c
   ipsec/ipsec_if_in.c
+  ipsec/ipsec_punt.c
   ipsec/ipsec_sa.c
   ipsec/ipsec_spd.c
   ipsec/ipsec_spd_policy.c
@@ -1588,6 +1594,12 @@ if(VPP_BUILD_SESSION_ECHO_APPS)
     DEPENDS api_headers
     NO_INSTALL
     )
+  add_vpp_executable(quic_echo
+    SOURCES ../tests/vnet/session/quic_echo.c
+    LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt
+    DEPENDS api_headers
+    NO_INSTALL
+    )
   add_vpp_executable(udp_echo
     SOURCES ../tests/vnet/session/udp_echo.c
     LINK_LIBRARIES vlibmemoryclient svm vppinfra pthread m rt