misc: vpe.api messages dynamically allocated
[vpp.git] / src / vpp / CMakeLists.txt
index 32f702d..32984c0 100644 (file)
@@ -85,8 +85,6 @@ add_vpp_executable(vpp
 )
 
 add_vpp_headers(vpp
-  api/vpe_msg_enum.h
-  api/vpe_all_api_h.h
   stats/stat_segment.h
   stats/stat_segment_shared.h
 )
@@ -141,6 +139,10 @@ add_vpp_test_library(vpp
   ${VPP_API_FILES}
 )
 
+add_vat_test_library(vpp
+  api/api_test.c
+)
+
 ##############################################################################
 # minimal interactive startup.conf  - only if not present
 ##############################################################################