vppinfra: native AES-CTR implementation
[vpp.git] / src / vppinfra / CMakeLists.txt
index d648471..6976ac5 100644 (file)
@@ -132,6 +132,7 @@ set(VPPINFRA_HEADERS
   crypto/ghash.h
   crypto/aes.h
   crypto/aes_cbc.h
+  crypto/aes_ctr.h
   crypto/aes_gcm.h
   crypto/poly1305.h
   dlist.h
@@ -285,6 +286,7 @@ endif(VPP_BUILD_VPPINFRA_TESTS)
 
 set(test_files
   test/aes_cbc.c
+  test/aes_ctr.c
   test/aes_gcm.c
   test/poly1305.c
   test/array_mask.c