api: API trace improvements
[vpp.git] / src / vppinfra / CMakeLists.txt
index 4be291e..1114092 100644 (file)
@@ -39,7 +39,7 @@ install(
 add_definitions(-fvisibility=hidden)
 
 # Ensure symbols from cJSON are exported
-set_source_files_properties( cJSON.c PROPERTIES
+set_source_files_properties( cJSON.c jsonformat.c PROPERTIES
   COMPILE_DEFINITIONS " CJSON_API_VISIBILITY " )
 
 
@@ -62,6 +62,7 @@ set(VPPINFRA_SRCS
   hash.c
   heap.c
   interrupt.c
+  jsonformat.c
   longjmp.S
   macros.c
   maplog.c
@@ -140,6 +141,7 @@ set(VPPINFRA_HEADERS
   hash.h
   heap.h
   interrupt.h
+  jsonformat.h
   lb_hash_hash.h
   llist.h
   lock.h