api: API trace improvements
[vpp.git] / src / vppinfra / CMakeLists.txt
index c682d70..1114092 100644 (file)
@@ -32,14 +32,14 @@ configure_file(
 
 install(
   FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h
-  DESTINATION include/vppinfra
+  DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/vppinfra
   COMPONENT vpp-dev
 )
 
 add_definitions(-fvisibility=hidden)
 
 # Ensure symbols from cJSON are exported
-set_source_files_properties( cJSON.c PROPERTIES
+set_source_files_properties( cJSON.c jsonformat.c PROPERTIES
   COMPILE_DEFINITIONS " CJSON_API_VISIBILITY " )
 
 
@@ -57,10 +57,12 @@ set(VPPINFRA_SRCS
   error.c
   fifo.c
   format.c
+  format_table.c
   graph.c
   hash.c
   heap.c
   interrupt.c
+  jsonformat.c
   longjmp.S
   macros.c
   maplog.c
@@ -134,10 +136,12 @@ set(VPPINFRA_HEADERS
   fifo.h
   file.h
   format.h
+  format_table.h
   graph.h
   hash.h
   heap.h
   interrupt.h
+  jsonformat.h
   lb_hash_hash.h
   llist.h
   lock.h