vppinfra: move unused code to extras/deprecated/vppinfra
[vpp.git] / src / vppinfra / CMakeLists.txt
index f2279d0..e667eb0 100644 (file)
@@ -47,7 +47,6 @@ set(VPPINFRA_SRCS
   elf.c
   elog.c
   error.c
-  fheap.c
   fifo.c
   format.c
   graph.c
@@ -68,7 +67,6 @@ set(VPPINFRA_SRCS
   random_isaac.c
   rbtree.c
   serialize.c
-  slist.c
   socket.c
   std-formats.c
   string.c
@@ -87,7 +85,6 @@ set(VPPINFRA_SRCS
   valloc.c
   vec.c
   vector.c
-  zvec.c
 )
 
 set(VPPINFRA_HEADERS
@@ -109,12 +106,6 @@ set(VPPINFRA_HEADERS
   clib.h
   cpu.h
   crc32.h
-  cuckoo_8_8.h
-  cuckoo_16_8.h
-  cuckoo_common.h
-  cuckoo_debug.h
-  cuckoo_template.h
-  cuckoo_template.c
   dlist.h
   dlmalloc.h
   elf_clib.h
@@ -122,12 +113,8 @@ set(VPPINFRA_HEADERS
   elog.h
   error_bootstrap.h
   error.h
-  fheap.h
   fifo.h
   file.h
-  flowhash_24_16.h
-  flowhash_8_8.h
-  flowhash_template.h
   format.h
   graph.h
   hash.h
@@ -149,7 +136,6 @@ set(VPPINFRA_HEADERS
   os.h
   pcap.h
   pcap_funcs.h
-  pipeline.h
   pmalloc.h
   pool.h
   pmc.h
@@ -160,7 +146,6 @@ set(VPPINFRA_HEADERS
   rbtree.h
   serialize.h
   sha2.h
-  slist.h
   smp.h
   socket.h
   sparse_vec.h
@@ -190,8 +175,6 @@ set(VPPINFRA_HEADERS
   vector_neon.h
   vector_sse42.h
   xxhash.h
-  xy.h
-  zvec.h
   linux/syscall.h
   linux/sysfs.h
 )
@@ -218,12 +201,10 @@ option(VPP_BUILD_VPPINFRA_TESTS "Build vppinfra tests." OFF)
 if(VPP_BUILD_VPPINFRA_TESTS)
   foreach(test
     bihash_vec88
-    cuckoo_template
     dlist
     elf
     elog
     fifo
-    flowhash_template
     format
     fpool
     hash
@@ -238,16 +219,13 @@ if(VPP_BUILD_VPPINFRA_TESTS)
     random_isaac
     rwlock
     serialize
-    slist
     socket
     spinlock
     time
     time_range
-    timing_wheel
     tw_timer
     valloc
     vec
-    zvec
   )
     add_vpp_executable(test_${test}
       SOURCES test_${test}.c
@@ -255,7 +233,7 @@ if(VPP_BUILD_VPPINFRA_TESTS)
       )
   endforeach()
 
-  foreach(test bihash_template cuckoo_bihash)
+  foreach(test bihash_template)
     add_vpp_executable(test_${test}
       SOURCES test_${test}.c
       LINK_LIBRARIES vppinfra Threads::Threads