feat(ansible): Add numactl dependency
[csit.git] / resources / tools / block_replacer / gpl2apache.sh
1 #!/usr/bin/env bash
2
3 # Copyright (c) 2021 Cisco and/or its affiliates.
4 # Licensed under the Apache License, Version 2.0 (the "License");
5 # you may not use this file except in compliance with the License.
6 # You may obtain a copy of the License at:
7 #
8 #     http://www.apache.org/licenses/LICENSE-2.0
9 #
10 # Unless required by applicable law or agreed to in writing, software
11 # distributed under the License is distributed on an "AS IS" BASIS,
12 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 # See the License for the specific language governing permissions and
14 # limitations under the License.
15
16 set -exuo pipefail
17
18 if [[ "${#}" != "1" ]]; then
19     echo 'An utility to switch license comment blocks.'
20     echo 'Requires files "gpl_block.txt" and "apache_block.txt" in the working'
21     echo 'directory, and a single argument pointing to root directory.'
22     echo 'Affects only .sh and .py files.'
23     exit 1
24 fi
25
26 find "${1}" \( -name "*.py" -o -name "*.sh" \) -print0 | xargs -0 \
27 python3 replace.py "gpl_block.txt" "apache_block.txt"
28
29 find "${1}" \( -name "*.py" -o -name "*.sh" \) -print0 | xargs -0 \
30 python3 replace.py "gpl_long_block.txt" "apache_block.txt"