New upstream version 17.11.4
[deb_dpdk.git] / pkg / dpdk.spec
1 # Copyright 2014 6WIND S.A.
2 #
3 # Redistribution and use in source and binary forms, with or without
4 # modification, are permitted provided that the following conditions
5 # are met:
6 #
7 # - Redistributions of source code must retain the above copyright
8 #   notice, this list of conditions and the following disclaimer.
9 #
10 # - Redistributions in binary form must reproduce the above copyright
11 #   notice, this list of conditions and the following disclaimer in
12 #   the documentation and/or other materials provided with the
13 #   distribution.
14 #
15 # - Neither the name of 6WIND S.A. nor the names of its
16 #   contributors may be used to endorse or promote products derived
17 #   from this software without specific prior written permission.
18 #
19 # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
20 # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
21 # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
22 # FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
23 # COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
24 # INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
25 # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
26 # SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
27 # HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
28 # STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
29 # ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
30 # OF THE POSSIBILITY OF SUCH DAMAGE.
31
32 Name: dpdk
33 Version: 17.11.4
34 Release: 1
35 Packager: packaging@6wind.com
36 URL: http://dpdk.org
37 Source: http://dpdk.org/browse/dpdk/snapshot/dpdk-%{version}.tar.gz
38
39 Summary: Data Plane Development Kit core
40 Group: System Environment/Libraries
41 License: BSD and LGPLv2 and GPLv2
42
43 ExclusiveArch: i686 x86_64 aarch64
44 %ifarch aarch64
45 %global machine armv8a
46 %global target arm64-%{machine}-linuxapp-gcc
47 %global config arm64-%{machine}-linuxapp-gcc
48 %else
49 %global machine default
50 %global target %{_arch}-%{machine}-linuxapp-gcc
51 %global config %{_arch}-native-linuxapp-gcc
52 %endif
53
54 BuildRequires: kernel-devel, kernel-headers, libpcap-devel
55 BuildRequires: doxygen, python-sphinx, inkscape
56 BuildRequires: texlive-collection-latexextra
57
58 %description
59 DPDK core includes kernel modules, core libraries and tools.
60 testpmd application allows to test fast packet processing environments
61 on x86 platforms. For instance, it can be used to check that environment
62 can support fast path applications such as 6WINDGate, pktgen, rumptcpip, etc.
63 More libraries are available as extensions in other packages.
64
65 %package devel
66 Summary: Data Plane Development Kit for development
67 Requires: %{name}%{?_isa} = %{version}-%{release}
68 %description devel
69 DPDK devel is a set of makefiles, headers and examples
70 for fast packet processing on x86 platforms.
71
72 %package doc
73 Summary: Data Plane Development Kit API documentation
74 BuildArch: noarch
75 %description doc
76 DPDK doc is divided in two parts: API details in doxygen HTML format
77 and guides in sphinx HTML/PDF formats.
78
79 %prep
80 %setup -q
81
82 %build
83 make O=%{target} T=%{config} config
84 sed -ri 's,(RTE_MACHINE=).*,\1%{machine},' %{target}/.config
85 sed -ri 's,(RTE_APP_TEST=).*,\1n,'         %{target}/.config
86 sed -ri 's,(RTE_BUILD_SHARED_LIB=).*,\1y,' %{target}/.config
87 sed -ri 's,(RTE_NEXT_ABI=).*,\1n,'         %{target}/.config
88 sed -ri 's,(LIBRTE_VHOST=).*,\1y,'         %{target}/.config
89 sed -ri 's,(LIBRTE_PMD_PCAP=).*,\1y,'      %{target}/.config
90 make O=%{target} %{?_smp_mflags}
91 make O=%{target} doc
92
93 %install
94 rm -rf %{buildroot}
95 make install O=%{target} DESTDIR=%{buildroot} \
96         prefix=%{_prefix} bindir=%{_bindir} sbindir=%{_sbindir} \
97         includedir=%{_includedir}/dpdk libdir=%{_libdir} \
98         datadir=%{_datadir}/dpdk docdir=%{_docdir}/dpdk
99
100 %files
101 %dir %{_datadir}/dpdk
102 %{_datadir}/dpdk/usertools
103 /lib/modules/%(uname -r)/extra/*
104 %{_sbindir}/*
105 %{_bindir}/*
106 %{_libdir}/*
107
108 %files devel
109 %{_includedir}/dpdk
110 %{_datadir}/dpdk/mk
111 %{_datadir}/dpdk/buildtools
112 %{_datadir}/dpdk/%{target}
113 %{_datadir}/dpdk/examples
114
115 %files doc
116 %doc %{_docdir}/dpdk
117
118 %post
119 /sbin/ldconfig
120 /sbin/depmod
121
122 %postun
123 /sbin/ldconfig
124 /sbin/depmod