Python API: Fixup of debian package after cFFI changes.
[vpp.git] / build-root / deb / debian / rules
1 #!/usr/bin/make -f
2 # See debhelper(7) (uncomment to enable)
3 # output every command that modifies files on the build system.
4 DH_VERBOSE = 1
5
6 # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
7 DPKG_EXPORT_BUILDFLAGS = 1
8 include /usr/share/dpkg/default.mk
9
10 # see FEATURE AREAS in dpkg-buildflags(1)
11 #export DEB_BUILD_MAINT_OPTIONS = hardening=+all
12
13 # see ENVIRONMENT in dpkg-buildflags(1)
14 # package maintainers to append CFLAGS
15 #export DEB_CFLAGS_MAINT_APPEND  = -Wall -pedantic
16 # package maintainers to append LDFLAGS
17 #export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
18
19 export PYBUILD_NAME = vpp-api-python
20 export PYBUILD_DIR = ../../src/vpp-api/python
21 export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
22 export PYBUILD_DISABLE_python2=test
23 export PYBUILD_SYSTEM=distutils
24
25 # main packaging script based on dh7 syntax
26 %:
27         dh $@ --with systemd,python2 --buildsystem=pybuild
28
29 override_dh_install:
30         dh_install --exclude .git
31         ../scripts/remove-rpath .
32
33 override_dh_shlibdeps:
34         @dh_shlibdeps 2>&1 \
35           | grep -v "probably a plugin" \
36           | grep -v "similar warnings have been skipped"
37
38 override_dh_strip:
39         dh_strip --dbg-package=vpp-dbg