L2-learn; cache prefetch fix
[vpp.git] / src / vnet / CMakeLists.txt
index 29f5fef..549b3ac 100644 (file)
@@ -120,7 +120,7 @@ list(APPEND VNET_SOURCES
   ethernet/p2p_ethernet_api.c
 )
 
-list(APPEND VNET_MULTIARCH_SOURCES ethernet/node.c l2/l2_output.c)
+list(APPEND VNET_MULTIARCH_SOURCES ethernet/node.c)
 
 list(APPEND VNET_HEADERS
   ethernet/error.def
@@ -158,6 +158,8 @@ list(APPEND VNET_SOURCES
   l2/l2_xcrw.c
 )
 
+list(APPEND VNET_MULTIARCH_SOURCES l2/l2_output.c l2/l2_learn.c)
+
 list(APPEND VNET_HEADERS
   l2/feat_bitmap.h
   l2/l2_input.h